Echec de migration NAS Synology


#1

Bonjour à tous,

j’ai migré du NAS DS411J à un DS418
avec 4 disques dur.

Après installation du nouveau dsm sur un disque vierge, j’ai monté mes 4 disques du 411j dans le 418 fraîchement installé.
La détection s’est bien faite et il m’a proposé de mettre à jour le DSM
Au redémarrage il reste bloqué au boot et la lumière bleu clignote.

Y a t-il moyen de réinstaller le dsm avec les 4 disques en place ?
Ou est-il possible d’installer dsm sur un disque vierge (capacité au moins équivalente aux disque de l’ancienne config) et de monter mon ancien volume avec les disques 2,3&4 et faire une réparation ?

Merci pour vous retours


#2

Hello,
Si j’ai bien compris, tu souhaites faire une migration des disques de ton syno vers un nouveau ISO config (même nombre de disque) ?

Jérémy


#3

Exactement !

tout aurait du se passer sans problème, le dsm s’est installé avec les disques de l’ancien serveur, sauf que maintenant il ne reboote plus, mes disques allaient tres bien dans l’ancienne config !

D’où ma question, peut-on mettre un disque neuf puis mettre les 3 autres disques afin de recréer le volume pour ensuite refaire la parité sur le nouveau disque.

Sinon je vais essayer la solution de linux pour copier les données, mais je n’aurai jamais assez de place pour tout stocker

Quelqu’un à déjà fait cette manip ?

En gros ça s’appelle recréer un volume existant sur nouveau nas sans passer par la migration…


#4

si ça se trouve en mettant le disque 1 neuf, et les disques 2,3,4 de l’ancienne config DSM va me proposer de récupérer le volume.

Je doute qu’ils aient pensé à ce cas et je veux pas tenter de peur de tout perdre !

J’ai bien sur contacté le support mais le délai de traitement étant ce qu’il est, j’essaie quand même de poser la question :wink:


#5

Et pourquoi pas avoir migré tous les disques puis ensuite ajouter le disque neuf ?
Un peu de documentation => https://www.synology.com/en-us/knowledgebase/DSM/tutorial/General/How_to_migrate_between_Synology_NAS_DSM_6_0_and_later


#6

Je pensais avoir été clair dans mes propos désolé !

J’ai suivi la procédure, à savoir installé le dsm sur un nouveau disque, puis retiré le disque pour mettre les 4 disques de l’ancien NAS
mais ça ne boote pas.

c’est + clair ?


#7

Je vois ce que tu veux dire mais ça n’est pas ma demande…

je ne cherche pas à rajouter un disque vierge puisque j’ai deja un volume de 4 disques de mon ancien NAS
que je tiens absolument à recuper, quitte a mettre 1 disque vierge avec un nouveau dsm dessus si je peux reinstaller mon ancien volume en refaisant la parité


#8

Oui j’ai bien compris.
As-tu suivi à partir de “2.2 Migrating between different Synology NAS models” ?

image


#9

Absolument, DSM s’est installé, puis à rebooté.
et c’est justement là qu’il est bloqué…


#10

Tu as essayé de rollback dans ton ancien Syno ?

Essayes d’aller faire un tour sur le forum des nas : https://www.forum-nas.fr/
Il y aura surement des personnes plus compétentes que moi sur le sujet et qui auront probablement déjà rencontré un cas similaire.

Jérémy


#11

Le soucis c’est que j’ai revendu mon ancien NAS.

Je vais aller m’inscrire sur le forum.

Merci d’avoir pris le temps de t’intéresser à mon soucis.

Bonne journée


#12

Pas de soucis, tiens moi au courant si tu as trouvé la solution, c’est toujours bon à prendre :slight_smile:
Bon courage.

Jérémy


#13

PROBLÈME RÉSOLU !!!

Après test des disques avec les outils constructeurs (voir réponse de Synology à la fin du message)
il s’est avéré que le disque 3 à échoué au test approfondi dans les 3 minutes.

Donc, j’ai rebooté le NAS sans disques, après le bip et redirection sur la page web par l’assistant, il me demande d’ajouter des disques.
J’ai inséré les HDD 1,2,4 et réinstallé le DSM (qui a mis + de temps qu’auparavant)
Reboot, puis bip de volume dégradé, config du mot de passe admin et me voilà logué correctement.
Un petit tour dans volume pour voir mon disque 3 apparaitre quand je le branche.
Puis la manip standard, initialiser le disque, puis réparer le volume.
La réparation est en cours, me voilà rassuré !!!
(pourtant tous les disques étaient ok sur l’ancien NAS)


Pouvez-vous démarrer le NAS sans disque ou avec le disque “vierge” ayant servi pour l’installation.

Comment le NAS se comporte t il?

Est-il reconnu par le synology assistant?

Si c’est le cas alors le souci viendra des disque pouvez-vous dans ce cas procéder à une analyse de vos disques?

Afin de confirmer l’état des disques, je vous suggère donc de faire un test smart étendu sur chacun des disques en utilisant les outils constructeurs:
[Samsung HDD: EStool]
http://www.seagate.com/fr/fr/support/downloads/item/samsung-eswin-master-dl/
[WD HDD: Lifeguard]
http://support.wdc.com/downloads.aspx?DL
[Seagate HDD: Seatool]
http://www.seagate.com/fr/fr/support/downloads/item/seatools-win-master/
[Hitachi HDD: Drive Fitness Test]
https://www.hgst.com/support/hard-drive-support/downloads

Veuillez noter que ces outils constructeurs s’installent sur l’ordinateur et nécessitent d’avoir le disque directement branché au PC, ce qui implique donc d’avoir un boitier externe dans lequel mettre le disque.

Si vous n’avez pas la possibilité, pour des raisons matérielles, de tester les disques via l’outil constructeur, alors vous pourrez toujours utiliser le test smart étendu proposé dans le gestionnaire de stockage dans la partie HDD/SSD, qui reste en revanche moins précis que les tests faits par l’outil constructeur.

Une fois les tests réalisés, vous pourrez nous envoyer les résultats pour confirmation.
Si des disques apparaissent comme défectueux, alors il faudra les remplacer.